企业新闻
当前位置:企业新闻

成都华三:ospf配置实例

来源:成都华三 时间:2016-12-16 22:07
 

   R1路由器的配置:

  帧中继静态映射、 NSSA网络类型及NSSA边界路由器的配置、 NSSA网络中的DR路由器和邻居路由器的配置、 区域网络的发布、 环回接口的配置、

  (config)#interface Loopback0

  (config-if)#ip address 10.1.1.1 255.255.255.0

  (config-if)# no shut

  (config)#interface Loopback1

  (config-if)#ip address 10.1.2.1 255.255.255.0

  (config-if)# no shut

  (config)#interface Loopback2

  (config-if)#ip address 10.1.3.1 255.255.255.0

  (config-if)# no shut //配置环回接口地址。

  interface FastEthernet0

  (config-if)#ip address 10.10.1.1 255.255.255.0

  (config-if)#no shut //配置 fast e0接口ip地址

  (config)#interface FastEthernet1

  (config-if)#ip address 172.16.4.1 255.255.255.0

  (config-if)#no shut //配置 fast e1接口ip地址

  (config-if)#ip ospf priority 10 //接口的优先级为10,把R8路由器接口的配为0,这样R1将为区域4中的DR

  (config)#inteface s0

  (config-if)ip address 172.16.1.1 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-if)#no frame-relay inverse-arp //取消动态反向ARP

  (config-if)#frame-relay map ip 172.16.1.2 100 broadcast //定义静态的帧中继,即静态的映射本地和远端的DLCI。对端IP为 172.16.1.2(R3的S0接口地址) ,dlci为 100。路由器之间是否广播与否与此处的broadcast无关。此处只是配置是否有广播或组播功能。就算有广播功能,邻居路由器之间不广播还是没用。

  (config-if)#frame-relay map ip 172.16.1.3 101 broadcast //定义静态的帧中继,对端IP为 172.16.1.3(R4的S0接口地址) ,dlci为 101

  (config-if)#ip ospf network non-broadcast //定义网络类型为NBMA,非广播。

  (config-if)#ip ospf priority 10 //接口的优先级为10,把R3和R4的接口定义为0,这样R1成为区域1的DR。

  (config)#router ospf 1

  (config-router)#network 10.1.1.0 0.0.0.255 area 0 //发布环回接口10.1.1.0参与ospf进程,且属于区域0

  (config-router)#network 10.1.2.0 0.0.0.255 area 0 //发布环回接口10.1.2.0参与ospf进程,且属于区域0

  (config-router)#network 10.1.3.0 0.0.0.255 area 0 //发布环回接口10.1.3.0参与ospf进程,且属于区域0

  (config-router)#network 10.10.1.0 0.0.0.255 area 0 //发布接口E0接口10.10.1.0属于区域0

  (config-router)#network 172.16.4.0 0.0.0.255 area 4 //发布接口E1 172.16.4.0属于区域4

  (config-router)#area 1 nssa //区域1属于 nssa区域

  (config-router)#area 1 nssa defaultinformation-originate //产生并传播默认路由到 nssa区域1中。只有边界路由器做此配置。所以只有R1路由器配置此命令,R1是边界路由器

  (config-router)#area 1 nssa no-summary //不把汇总路由传进NSSA区域

  (config-router)#neighbor 172.16.1.3 priority 0 //设定邻居路由器。因为区域1网络设定为NBMA网络,为no-broadcast。不广播消息,所以需要手工配置邻居。且把对方设优先级设为0.

  (config-router)#neighbor 172.16.1.2 priority 0 //手工设定邻居路由器。只有 point-to-point型NBMA网络和 点到多点型NAMA网络才不需要neighbor命令手工设定邻居。且把对方设优先级设为0.

  (config-router)#area 4 virtual-link 10.8.1.1 authentication authentication-key cisco //定义虚拟链路,把区域5经过中转区域4,再与区域0相连。并且认证文本为cisco

  (config-router)#area 0 rang 10.1.0.0 255.255.0.0 //把区域0里的环回接口IP地址汇总

  R2路由器的配置:

  (config)#interface Loopback0

  (config-if)ip address 10.2.1.1 255.255.255.0 //定义环回接口地址

  (config-if)# no shut

  interface FastEthernet0

  (config-if)#ip address 10.10.1.2 255.255.255.0

  (config-if)#no shut

  (config)#inteface s0

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-if)#ip ospf network point-to-point //指定网络为NBMA的点到点网络类型。

  (config-if)#interface s0.11 point-to-point //定义子接口 s0.11,且为点到点类型。还有一种为点到多点

  (config-subif)#ip adderss 172.16.2.1 255.255.255.0 //定义子接口的IP地址,多个子接口要属于不同子网

  (config-subif)#encapsulation frame-relay ietf //子接口封装为帧中继

  (config-subif)#frame-relay interface-dlci 100 //动态的映射本地DLCI和远端DLCI,此处的100为本地DLCI值。

  (config-if)#interface s0.12 point-to-point //定义子接口 s0.11,且为点到点类型

  (config-subif)#ip adderss 172.16.3.1 255.255.255.0 //定义子接口的IP地址

  (config-subif)#encapsulation frame-relay ietf //子接口封装为帧中继

  (config-subif)#frame-relay interface-dlci 101 //动态的映射本地DLCI和远端DLCI,此处的101为本地DLCI值

  (config)#router ospf 1

  (config-router)#network 172.16.2.0 0.0.0.255 area 2

  (config-router)#network 10.2.1.0 0.0.0.255 area 0

  (config-router)#network 10.10.1.0 0.0.0.255 area 0 //发布所属接口参与哪个区域的OSPF进程

  (config-router)#area 2 stub no-summary //把区域2配置成绝对末节区域。只有在绝对末节域的边界路由器上才需要加上 no-summary关键字。不把汇总传到完本末节区域内

  //因为NBMA网络的点到点类型不需要选举DR路由器,所以不需要指定优先级

  (config-router)#summary

  (config-router)#redistribute eigrp 100 metric 100 subnets //把EIGRP中的路由重分发到OSPF中,且METRIC值为100。且分发子网

  (config-router)#default-information originate always //把EIGRP的默认路由通告给OSPF网络中。

  (config)#router eigrp 100 //配置eigrp进程

  (config-router)#network 172.18.1.0 255.255.255.0 //发布参与EIGRP进程的网络

  (config-router)#no auto-summary //不进行自动汇总

  (config-router)#redistribute ospf 1 metric 10000 100 255 1 1500 subnets //把OSPF 1中的路由分发到EIGRP中去。

  R3路由器的配置:

  (config)#interface Loopback0

  (config-if)#ip address 10.3.1.1 255.255.255.0

  (config-if)# no shut //配置环回接口地址。

  interface FastEthernet0

  (config-if)#ip address 10.10.1.1 255.255.255.0

  (config-if)#no shut //配置 fast e0接口ip地址

  (config)#inteface s0

  (config-if)ip address 172.16.1.2 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-if)#no frame-relay inverse-arp //取消动态反向ARP

  (config-if)#frame-relay map ip 172.16.1.1 99 broadcast //定义静态的帧中继,即静态的映射本地和远端的DLCI。这里的远端为R1的S0接口IP和dlci号

  (config-if)#ip ospf network non-broadcast //定义网络类型为NBMA,非广播。

  (config-if)#ip ospf priority 0 //接口的优先级为0

  (config)#router ospf 1

  (config-router)#network 172.16.1.0 area 1

  (config-router)#network 10.3.1.0 area 1 //环回接口也为区域1

  (config-router)#area 1 nssa //区域1属于 nssa区域

  R4路由器的配置:

  (config)#interface Loopback0

  (config-if)#ip address 10.4.1.1 255.255.255.0

  (config-if)# no shut //配置环回接口地址。

  (config)#inteface s0

  (config-if)ip address 172.16.1.3 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-if)#no frame-relay inverse-arp //取消动态反向ARP

  (config-if)#frame-relay map ip 172.16.1.1 99 broadcast //定义静态的帧中继,即静态的映射本地和远端的DLCI。这里的远端DLCI为R1的S0接口IP。

  (config-if)#ip ospf network non-broadcast //定义网络类型为NBMA,非广播。

  (config-if)#ip ospf priority 0 //接口的优先级为0

  config)#inteface s1

  (config-if)ip address 172.17.1.1 255.255.255.0

  (config-if)#no shut //配置 s1 ip地址

  (config)#router rip

  (config-router)#version 2

  (config-router)#network 172.17.1.0 255.255.255.0 //参与RIP路由进程的RIP

  (config-router)#no auto-summary //不自动进行汇总

  (config)#router ospf 1

  (config-router)#network 172.16.1.0 area 1

  (config-router)#network 10.4.1.0 area 1 //环回接口也为区域1

  (config-router)#area 1 nssa //区域1属于 nssa区域

  (config-router)#redistribute rip metric 100 metric-type 1 subnets //把rip路由选择AS中的路由重分发到OSPF中,且到OSPF中的外部路由类型为 1,且同时分发子网。

  (config-router)#summary-address 172.17.0.0 255.255.0.0 //汇总外部路由,即把从OSPF自治系统外部分发进来的路由进行汇总。这里假设了R7路由器连接了172.17.2.0和172.17.3.0的网络。

  (config-router)#default-information originate always [metric 50] //把默认路由通告给OSPF区域。即把到达RIP网络的默认路由通告给OSPF区域,不是把OSPF网络的默认路由通告给RIP。在NSSA区域的边界路由器上是把默认路由通告给常规区域。

  //当有多条路由通告到OSPF区域时,后面加上度量值,以选择最优的默认路由。

  //(config-router)#neighbor 172.16.3.1

  //这条在这里不用设定设定。因为已经在R2路由器的S0把NBMA网络定义为点到点类型了。如果只在环回接口上定义了类型为点到点类型的NBMA网,则此处需定义邻居,否则不会和R1成为邻居。

  R5路由器的配置:

  (config)#interface Loopback0

  (config-if)#ip address 10.5.1.1 255.255.255.0

  (config-if)# no shut //配置环回接口地址。

  (config)#inteface s0

  (config-if)ip address 172.16.2.1 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-subif)#frame-relay interface-dlci 101 //动态的映射本地DLCI和远端DLCI,此处的101为本地DLCI值

  (config-if)#ip ospf network point-to-point //定义网络类型为点对点

  (config)#router ospf 1

  (config-router)#network 172.16.2.0 area 2

  (config-router)#network 10.5.1.0 area 2 //环回接口也为区域2

  (config-router)#area 2 stub //把区域2配置成绝对末节区域。只有在绝对末节域的边界路由器上才需要加上 no-summary关键字。不把汇总传到完本末节区域内

  //因为NBMA网络的点到点类型不需要选举DR路由器,所以不需要指定优先级

  R6路由器的配置:

  (config)#interface Loopback0

  (config-if)#ip address 10.6.1.1 255.255.255.0

  (config-if)# no shut //配置环回接口地址。

  (config)#inteface s0

  (config-if)ip address 172.16.3.1 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-subif)#frame-relay interface-dlci 102 //动态的映射本地DLCI和远端DLCI,此处的101为本地DLCI值

  (config-if)#ip ospf network point-to-point //定义网络类型为点对点

  (config)#router ospf 1

  (config-router)#network 172.16.2.0 area 2

  (config-router)#network 10.6.1.0 area 2 //环回接口也为区域2

  (config-router)#area 2 stub //把区域2配置成绝对末节区域。只有在绝对末节域的边界路由器上才需要加上 no-summary关键字。不把汇总传到完本末节区域内

  //因为NBMA网络的点到点类型不需要选举DR路由器,所以不需要指定优先级

  R7的配置:

  (config)#interface Loopback0

  (config-if)#ip address 10.7.1.1 255.255.255.0

  (config-if)#no shut

  (config)#inteface s0

  (config-if)ip address 172.17.1.2 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  interface FastEthernet0

  (config-if)#ip address 192.168.8.1 255.255.255.0

  (config-if)#no shut //配置 fast e0接口ip地址

  config)#router rip

  (config-router)#version 2

  (config-router)#network 172.17.1.0 255.255.255.0 //参与RIP路由进程的RIP

  (config-router)#network 10.7.1.0 255.255.255.0 //环回接口网段

  (config-router)#network 172.17.2.0 255.255.255.0

  (config-router)#network 172.17.3.0 255.255.255.0

  (config-router)#no auto-summary //不自动进行汇总

  R8的配置

  (config)#interface Loopback0

  (config-if)#ip address 10.8.1.1 255.255.255.0

  (config-if)# no shut //配置环回接口地址。

  interface FastEthernet0

  (config-if)#ip address 172.16.4.2 255.255.255.0 //配置 fast e0接口ip地址

  (config-if)#no shut

  (config-if)#ip ospf priority 0 //定义此接口在172.16.4.0网段的优先级,优先级为0,所以不能成为DR

  (config)#inteface s0

  (config-if)ip address 172.16.5.1 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  (config-if)#encapsulation frame-relay ietf //so接口封装成帧中继,且类型为ietf

  (config-if)#no frame-relay inverse-arp //取消动态反向ARP

  (config-if)#frame-relay map ip 172.16.5.2 100 broadcast //定义静态的帧中继,即静态的映射本地和远端的DLCI。

  (config-if)#ip ospf network point-to-point //定义网络类型为点到点类型的NBMA

  (config)#router ospf 1

  (config-router)#network 172.16.4.0 area 4

  (config-router)#network 10.8.1.0 area 4

  (config-router)#network 172.16.5.0 area 5

  (config-router)#area 5 stub

  (config-router)#area 4 virtual-link 10.1.1.1 authentication authentication-key cisco //此处的10.1.1.1为路由器R1的ROUTER ID。虚拟链路对端路由器和ROUTER ID,而不是对端路由器的接口IP。 区域4指的是中转区域号

  R9的配置:

  (config)#interface Loopback0

  (config-if)#ip address 10.9.1.1 255.255.255.0

  (config-if)#no shut

  (config)#inteface s0

  (config-if)ip address 172.18.1.2 255.255.255.0

  (config-if)#no shut //配置 s0 ip地址

  interface FastEthernet0

  (config-if)#ip address 192.168.1.1 255.255.255.0

  (config-if)#no shut //配置 fast e0接口ip地址。因为要接多个网段,就需要在此接口上接三层交换机,在此接口上配置子接口。在此不作解释。

  (config)#router eigrp 100 //配置eigrp进程

  (config-router)#network 172.18.1.0 255.255.255.0 //发布参与EIGRP进程的网络

  (config-router)#network 192.168.1.0 255.255.255.0

  (config-router)#network 192.168.2.0 255.255.255.0

  (config-router)#no auto-summary //不进行自动汇总

  希望我们成都华三的相关分享可以帮助到您!


上一篇:成都华三:路由器作NAT和端口映射
下一篇:成都华三:BGP学习笔记
   蜀ICP备2020034250号-1   川公网安备 51010802000119号

售前客服

售前客服

电话:028-83252151

传真:028-85259033

咨询热线:15378180513
在线客服