组网及说明
要求正常情况下RT1和RT2互访时通过link1转发,当该路径中任意线路异常后改由link2转发,通过bfd多跳检测实现
配置步骤
RT1主要配置:
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
interface GigabitEthernet0/0
ip address 10.1.123.1 255.255.255.0
#
bfd static test peer-ip 4.4.4.4 source-ip 1.1.1.1 discriminator local 1998 remote 1998
#
ip route-static 4.4.4.4 32 10.1.123.2
ip route-static 10.1.234.4 32 10.1.123.2 bfd static test
ip route-static 10.1.234.4 32 10.1.123.3 preference 65
#
RT2主要配置:
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
#
interface GigabitEthernet0/0
ip address 10.1.234.4 255.255.255.0
#
bfd static test peer-ip 1.1.1.1 source-ip 4.4.4.4 discriminator local 1998 remote 1998
#
ip route-static 1.1.1.1 32 10.1.234.2
ip route-static 10.1.123.1 32 10.1.234.2 bfd static test
ip route-static 10.1.123.1 32 10.1.234.3 preference 65
#
验证
RT1侧:
<RT1>dis bfd session verbose
Total sessions: 1 Up sessions: 1 Init mode: Active
IPv4 static session working in control packet mode:
Session name: test
Local discr: 1998 Remote discr: 1998
Source IP: 1.1.1.1 Destination IP: 4.4.4.4
Session state: Up
Interface: N/A
Min Tx interval: 1000ms Actual Tx interval: 1000ms
Min Rx interval: 1000ms Detection time: 5000ms
Rx count: 1949 Tx count: 1962
Connection type: Indirect Up duration: 00:21:57
Hold time: 4243ms Auth mode: None
Detection mode: Async Slot: 0
Protocol: STATIC4/STATIC_IPv4
Version: 1
Diag info: No Diagnostic
静态路由:
<RT1>dis ip routing-table protocol static
Summary count : 2
Static Routing table status : <Active>
Summary count : 2
Destination/Mask Proto Pre Cost NextHop Interface
4.4.4.4/32 Static 60 0 10.1.123.2 GE0/0
10.1.234.4/32 Static 60 0 10.1.123.2 GE0/0
RT2侧:
<RT2>dis bfd session verbose
Total sessions: 1 Up sessions: 1 Init mode: Active
IPv4 static session working in control packet mode:
Session name: test
Local discr: 1998 Remote discr: 1998
Source IP: 4.4.4.4 Destination IP: 1.1.1.1
Session state: Up
Interface: N/A
Min Tx interval: 1000ms Actual Tx interval: 1000ms
Min Rx interval: 1000ms Detection time: 5000ms
Rx count: 1945 Tx count: 2113
Connection type: Indirect Up duration: 00:24:31
Hold time: 4993ms Auth mode: None
Detection mode: Async Slot: 0
Protocol: STATIC4/STATIC_IPv4
Version: 1
Diag info: No Diagnostic
静态路由:
<RT2>dis ip routing-table protocol static
Summary count : 2
Static Routing table status : <Active>
Summary count : 2
Destination/Mask Proto Pre Cost NextHop Interface
1.1.1.1/32 Static 60 0 10.1.234.2 GE0/0
10.1.123.1/32 Static 60 0 10.1.234.2 GE0/0
模拟故障,断开link1与RT1之间的连通链路:
[link1]int g0/0
[link1-GigabitEthernet0/0]shutdown
RT1侧:
<RT1>%Jul 27 21:34:32:773 2023 RT1 BFD/5/BFD_CHANGE_FSM: Sess[1.1.1.1/4.4.4.4, LD/RD:1998/1998, Interface:N/A, SessType:Ctrl, LinkType:INET], Ver:1, Sta: UP->DOWN, Diag: 1 (Control Detection Time Expired)
<RT1>dis bfd session verbose
Total sessions: 1 Up sessions: 0 Init mode: Active
IPv4 static session working in control packet mode:
Session name: test
Local discr: 1998 Remote discr: 1998
Source IP: 1.1.1.1 Destination IP: 4.4.4.4
Session state: Down
Interface: N/A
Min Tx interval: 1000ms Actual Tx interval: 1000ms
Min Rx interval: 1000ms Detection time: 5000ms
Rx count: 2232 Tx count: 2254
Connection type: Indirect Up duration: 00:00:00
Hold time: 0ms Auth mode: None
Detection mode: Async Slot: 0
Protocol: STATIC4/STATIC_IPv4
Version: 1
Diag info: Control Detection Time Expired
<RT1>dis ip routing-table protocol static
Summary count : 2
Static Routing table status : <Active>
Summary count : 2
Destination/Mask Proto Pre Cost NextHop Interface
4.4.4.4/32 Static 60 0 10.1.123.2 GE0/0
10.1.234.4/32 Static 65 0 10.1.123.3 GE0/0
Static Routing table status : <Inactive>
Summary count : 0
RT2侧:
<RT2>%Jul 27 21:36:36:615 2023 RT2 BFD/5/BFD_CHANGE_FSM: Sess[4.4.4.4/1.1.1.1, LD/RD:1998/1998, Interface:N/A, SessType:Ctrl, LinkType:INET], Ver:1, Sta: UP->DOWN, Diag: 1 (Control Detection Time Expired)
<RT2>dis ip routing-table protocol static
Summary count : 2
Static Routing table status : <Active>
Summary count : 2
Destination/Mask Proto Pre Cost NextHop Interface
1.1.1.1/32 Static 60 0 10.1.234.2 GE0/0
10.1.123.1/32 Static 65 0 10.1.234.3 GE0/0
Static Routing table status : <Inactive>
Summary count : 0
<RT2>dis bfd session ver
Total sessions: 1 Up sessions: 0 Init mode: Active
IPv4 static session working in control packet mode:
Session name: test
Local discr: 1998 Remote discr: 1998
Source IP: 4.4.4.4 Destination IP: 1.1.1.1
Session state: Down
Interface: N/A
Min Tx interval: 1000ms Actual Tx interval: 1000ms
Min Rx interval: 1000ms Detection time: 5000ms
Rx count: 2118 Tx count: 2367
Connection type: Indirect Up duration: 00:00:00
Hold time: 0ms Auth mode: None
Detection mode: Async Slot: 0
Protocol: STATIC4/STATIC_IPv4
Version: 1
Diag info: Control Detection Time Expired