技术文档
当前位置:技术文档

华为CE交换机和S系列交换机配置dhcp的差异

来源:未知 时间:2022-08-24 11:36
 

   

  S交换机配置dhcp有“基于全局地址池”和“基于接口地址池”两种方法。

  CE交换机V300版本配置dhcp有“基于全局地址池”和“基于接口地址池”两种方法。且配置方法和S交换机的一致,需要在接口下配置dhcp select命令。唯一不同的是CE交换机配好功能后需要commit提交。

  CE交换机V200版本配置dhcp只有一种方式:基于全局方式的地址池。没有接口方式地址池。V200版本是先配置dhcp服务和地址池,再配置接口分配地址。且无需在接口下配dhcp select global命令。

  如下是dhcp关键配置举例,还有更多功能此处未列举。现网配置以实际需求为准。案例仅供参考。

  【S交换机基于接口地址池配置举例】

  1、配置接口IP地址(步骤1为基础配置,如已经配置好,可忽略)。

   system-view //进入系统视图

  [Switch] vlan batch 10 //创建vlan

  [Switch] interface gigabitethernet 0/0/1 //进入GE0/0/1接口

  [Switch-GigabitEthernet0/0/1] port link-type access //配置接口vlan类型为access

  [Switch-GigabitEthernet0/0/1] port default vlan 10 //配置接口加入vlan10

  [Switch-GigabitEthernet0/0/1] quit //退出

  [Switch] interface vlanif 10

  [Switch-Vlanif10] ip address 10.1.1.1 24 //配置VLANIF10接口地址

  [Switch-Vlanif10] quit

  2、能dhcp服务。

  [Switch] dhcp enable

  3、配置接口地址池。配置VLANIF10接口下的客户端从接口地址池中获取IP地址和相关网络参数。

  [Switch] interface vlanif 10

  [Switch-Vlanif10] dhcp select interface //配置基于接口的dhcp

  [Switch-Vlanif10] dhcp server gateway-list 10.1.1.1 //配置网关地址

  [Switch-Vlanif10] dhcp server dns-list 10.1.3.1 //(可选)配置dns服务器

  [Switch-Vlanif10] dhcp server lease day 30 //(可选)配置租期

  [Switch-Vlanif10] dhcp server excluded-ip-address 10.1.1.2 10.1.1.3 //(可选)配置需要排除的IP地址

  [Switch-Vlanif10] dhcp server static-bind ip-address 10.1.1.100 mac-address 00e0-fc12-3456 //(可选)配置IP和MAC地址绑定,给固定MAC分配固定IP

  [Switch-Vlanif10] dhcp server domain-name example.com //(可选)分配给DHCP客户端的DNS域名后缀

  [Switch-Vlanif10] quit

  【S交换机基于全局地址池配置举例】

  1、配置接口IP地址(步骤1为基础配置,如已经配置好,可忽略)。

   system-view //进入系统视图

  [Switch] vlan batch 10 //创建vlan

  [Switch] interface gigabitethernet 0/0/1 //进入GE0/0/1接口

  [Switch-GigabitEthernet0/0/1] port link-type access //配置接口vlan类型为access

  [Switch-GigabitEthernet0/0/1] port default vlan 10 //配置接口加入vlan10

  [Switch-GigabitEthernet0/0/1] quit //退出

  [Switch] interface vlanif 10

  [Switch-Vlanif10] ip address 10.1.1.1 24 //配置VLANIF10接口地址

  [Switch-Vlanif10] quit

  2、使能DHCP服务。

  [Switch] dhcp enable

  3、创建地址池并在地址池视图下为PC配置网关地址、租期和DNS服务器地址;

  [Switch] ip pool pool1

  [Switch-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.0 //配置dhcp分配的IP范围

  [Switch-ip-pool-pool1] gateway-list 10.1.1.1 //配置网关地址

  [Switch-ip-pool-pool1] dns-list 10.1.1.2 //(可选)配置dns服务器

  [Switch-ip-pool-pool1] lease day 10 hour 0 minute 0 //(可选)配置租期

  [Switch-ip-pool-pool1] excluded-ip-address 10.1.1.2 10.1.1.3 //(可选)配置保留地址,这部分地址不会分配出去

  [Switch-ip-pool-pool1] static-bind ip-address 10.1.1.4 mac-address 00e0-fc12-3456 //(可选)配置IP和MAC地址绑定,给固定MAC分配固定IP

  [Switch-ip-pool-pool1] domain-name example.com //(可选)分配给DHCP客户端的DNS域名后缀 [Switch-ip-pool-pool1] quit

  [Switch] interface vlanif 10

  [Switch-Vlanif10] dhcp select global //配置基于全局地址池的dhcp

  [Switch-Vlanif10] quit

  【CE交换机(V200版本)配置dhcp服务举例】

  注意:CE交换机配置后需要commit提交才生效)

  1、使能DHCP服务。

   system-view

  [~SwitchB] dhcp enable

  [~SwitchB] dhcp server request-packet all-interface enable //V2R19 版本后需要配置该命令

  [*SwitchB] commit

  2、配置IP地址池1的属性(地址池范围、DNS地址、出口网关和地址池租期)。

  [~SwitchB] ip pool pool1

  [*SwitchB-ip-pool-pool1] gateway-list 10.1.1.1

  [*SwitchB-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.128

  [*SwitchB-ip-pool-pool1] dns-list 10.1.1.2

  [*SwitchB-ip-pool-pool1] excluded-ip-address 10.1.1.2

  [*SwitchB-ip-pool-pool1] lease day 10

  [*SwitchB-ip-pool-pool1] commit

  [~SwitchB-ip-pool-pool1] quit

  3、配置接口IP地址,以及配置VLANIF接口下地址分配方式。

  [~SwitchB] vlan batch 10 //创建vlan10

  [*SwitchB] interface 10ge 1/0/1

  [*SwitchB-10GE1/0/1] port link-type access //配置接口vlan类型为access

  [*SwitchB-10GE1/0/1] port default vlan 10 //配置接口加入vlan10

  [*SwitchB-10GE1/0/1] commit //提交

  [~SwitchB-10GE1/0/1] quit

  [~SwitchB] interface vlanif 10

  [*SwitchB-Vlanif10] ip address 10.1.1.1 255.255.255.128 // 配置接口VLANIF10的IP地址

  [*SwitchB-Vlanif10] commit

  [~SwitchB-Vlanif10] quit


上一篇:华为路由器AR161W-S最新版升级固件
下一篇:H3C MSR5660路由器双路供电时掉电一路后触发整机重启一例
蜀ICP备2020034250号-1   川公网安备 51010802000119号 keywords:成都H3C 成都H3C

售前客服

售前客服

电话:028-83252151

传真:028-85259033

咨询热线:15378180513
在线客服