技术文档
当前位置:技术文档

H3C架设vlan案例推荐

来源:未知 时间:2014-06-20 22:37
 

  一客户需求

  买三层交换机,进行vlan架设!

  电脑数量在200多台!

  请问有那款可以推荐的吗?

  要求不是很高!目前只是想通过三层交换机进行网络分段

  比如根据IP地址,分为几个vlan,

  vlan1 服务器 vlan2 笔记本 vlan3 网络打印机 vlan4 老总电脑

  公司有三栋大楼!

  基本思路是 一栋办公楼放三层交换,另外2栋放二层交换机。还有一些是普通交换机,接二层交换机下可以实现吗?

  

 

  首先是三层交换机的配置

  Ruijie>enable ------>进入特权模式

  Ruijie#configure terminal ------>进入全局配置模式

  sdk_1(config)#hostname sdk_1 ------>配置交换机的名字为sdk_1

  sdk_1(config)#interface vlan 1 ------>进入vlan 1

  sdk_1(config-if)#ip address 192.168.1.1 255.255.255.0 ------>为vlan 1设置管理ip

  sdk_1(config-if)#exit ------>退回到全局模式

  sdk_1(config)#line vty 0 4 ------> 进入telnet密码配置模式

  sdk_1(config-line)#login ------>启用需输入密码才能telnet成功

  sdk_1(config-line)#password 123 ------> 将telnet密码设置为123

  sdk_1(config-line)#exit ------> 回到全局配置模式

  sdk_1(config)# enable secret 123 ------>配置进入特权模式的密码为123

  sdk_1(config)#enable service web-server ------>全局web功能

  sdk_1(config)#vlan 10 name guanli ------>

  sdk_1(config)#vlan 20 name xiaoshou ------>

  sdk_1(config)#vlan 30 name jishu ------>

  sdk_1(config)#vlan 40 name caigou ------> 建立各部门的vlan

  sdk_1(config)#vlan 50 name caiwu ------>

  sdk_1(config)#vlan 60 name zongjingban ------>

  sdk_1(config)#vlan 70 name changqu ------>

  sdk_1(config)#vlan 80 name nvr ------>

  sdk_1(config)#interface vlan 10 ------>进入vlan 10

  sdk_1(config-if-VLAN 10)#ip address 172.21.10.254 255.255.255.0 ------>配置各个vlan的地址

  sdk_1(config-if-VLAN 10)#exit

  sdk_1(config)#interface vlan 20 ------>进入vlan 20

  sdk_1(config-if-VLAN 20)#ip address 172.21.20.254 255.255.255.0

  sdk_1(config-if-VLAN 20)#exit

  sdk_1(config)#interface vlan 30 ------>进入vlan 30

  sdk_1(config-if-VLAN 30)#ip address 172.21.30.254 255.255.255.0

  sdk_1(config-if-VLAN 30)#exit

  sdk_1(config)#interface vlan 20 ------>进入vlan 40

  sdk_1(config-if-VLAN 40)#ip address 172.21.40.254 255.255.255.0

  sdk_1(config-if-VLAN 40)#exit

  sdk_1(config)#interface vlan 20 ------>进入vlan 50

  sdk_1(config-if-VLAN 50)#ip address 172.21.50.254 255.255.255.0

  sdk_1(config-if-VLAN 50)#exit

  sdk_1(config)#interface vlan 20 ------>进入vlan 60

  sdk_1(config-if-VLAN 60)#ip address 172.21.60.254 255.255.255.0

  sdk_1(config-if-VLAN 60)#exit

  sdk_1(config)#interface vlan 20 ------>进入vlan 70

  sdk_1(config-if-VLAN 70)#ip address 172.21.70.254 255.255.255.0

  sdk_1(config-if-VLAN 70)#exit

  sdk_1(config)#interface vlan 20 ------>进入vlan 80

  sdk_1(config-if-VLAN 80)#ip address 172.21.80.254 255.255.255.0

  sdk_1(config-if-VLAN 80)#exit

  sdk_1 (config)#service dhcp ---->开启dhcp server功能

  sdk_1 (config)#ip dhcp ping packets 1

  ---->在dhcp server分配IP时会先去检测将要分配的IP地址是否已有人使用,如果没人使用则分配,若已有人使用则再分配下一个IP

  sdk_1 (config)#ip dhcp excluded-address 172.21.10.1 172.21.10.100

  sdk_1 (config)#ip dhcp excluded-address 172.21.10.141 172.21.10.254

  ---->设置地址为172.21.10.101至172.21.10.140的ip地址分配给客户端

  sdk_1 (config)#ip dhcp excluded-address 172.21.20.1 172.21.20.100

  sdk_1 (config)#ip dhcp excluded-address 172.21.20.161 172.21.20.254

  ---->设置地址为172.21.20.101至172.21.20.160的ip地址分配给客户端

  sdk_1 (config)#ip dhcp excluded-address 172.21.60.1 172.21.60.100

  sdk_1 (config)#ip dhcp excluded-address 172.21.60.121 172.21.60.254

  ---->设置地址为172.21.60.101至172.21.60.120的ip地址分配给客户端

  sdk_1 (config)#ip dhcp pool guanli ---->新建一个dhcp地址池名为guanli

  sdk_1 (dhcp-config)# lease 0 12 ---->租期时间设置为12 小时

  sdk_1 (dhcp-config)# network 172.21.10.0 255.255.255.0 ----给客户端分配的地址段

  sdk_1 (dhcp-config)# dns-server 61.177.7.1 ---->给客户端分配的DNS

  sdk_1(dhcp-config)# default-router 172.21.10.254

  sdk_1(dhcp-config)#exit

  sdk_1(config)#ip dhcp pool xiaoshou

  sdk_1(dhcp-config)# lease 0 12

  sdk_1(dhcp-config)# network 172.21.20.0 255.255.255.0

  sdk_1(dhcp-config)# dns-server 61.177.7.1

  sdk_1(dhcp-config)# default-router 172.21.20.254

  sdk_1(dhcp-config)#exit

  sdk_1(config)#ip dhcp pool zongjingban

  sdk_1(dhcp-config)# lease 0 12

  sdk_1(dhcp-config)# network 172.21.60.0 255.255.255.0

  sdk_1(dhcp-config)# dns-server 61.177.7.1

  sdk_1(dhcp-config)# default-router 172.21.60.254

  sdk_1(dhcp-config)#exit

  sdk_1(config)#interface range gigabitEthernet 0/25-26 ---->进入交换机的25和26口

  sdk_1(config-if-range)#switchport mode trunk ---->封装为trunk模式

  sdk_1(config-if-range)#exit

  sdk_1(config)#interface range fastEthernet 0/13-24 ---->进入交换机的13-24口

  sdk_1(config-if-range)#switchport access vlan 1 ---->加入到vlan 1

  sdk_1(config-if-range)#exit

  sdk_1(config)#interface fastEthernet 0/1 ---->进入交换机的1口

  sdk_1(config-if-FastEthernet 0/1)#no switchport ---->开启路由模式

  sdk_1(config-if-FastEthernet 0/1)#ip address 192.168.2.2 255.255.255.0 ---->配置地址

  sdk_1(config-if-FastEthernet 0/1)#no shutdown ---->开启该接口

  sdk_1(config-if-FastEthernet 0/1)#exit

  sdk_1(config)#ip access-list 100 deny ip 172.21.10 0.0.0.255 172.21.50.0 0.0.0.255 ---->禁止除了总经办的人访问财务部电脑

  sdk_1(config)#ip access-list 100 permit ip any any ------>ACL默认最后一句是deny ip any any ,故为保证其他数据能通过必须配置一条permit ip any any

  sdk_1(config)#ip access-list 101 deny ip 172.21.20 0.0.0.255 172.21.50.0 0.0.0.255 ---->禁止除了总经办的人访问财务部电脑

  sdk_1(config)#ip access-list 101 permit ip any any

  sdk_1(config)#ip access-list 102 deny ip 172.21.30 0.0.0.255 172.21.50.0 0.0.0.255 ---->禁止除了总经办的人访问财务部电脑

  sdk_1(config)#ip access-list 102 permit ip any any

  sdk_1(config)#ip access-list 103 deny ip 172.21.40 0.0.0.255 172.21.50.0 0.0.0.255 ---->禁止除了总经办的人访问财务部电脑

  sdk_1(config)#ip access-list 103 permit ip any any

  sdk_1(config)#ip access-list 104 deny ip 172.21.70 0.0.0.255 172.21.50.0 0.0.0.255 ---->禁止除了总经办的人访问财务部电脑

  sdk_1(config)#ip access-list 104 permit ip any any

  sdk_1(config)#ip access-list 105 deny ip 172.21.80 0.0.0.255 172.21.50.0 0.0.0.255 ---->禁止除了总经办的人访问财务部电脑

  sdk_1(config)#ip access-list 105 permit ip any any

  sdk_1(config)#interface vlan 10

  sdk_1(config-if-VLAN 10)#ip access-group 100 in ------>在 vlan10的网关上应用ACL

  sdk_1(config-if-VLAN 10)#exit

  sdk_1(config)#interface vlan 20

  sdk_1(config-if-VLAN 20)#ip access-group 101 in ------>在 vlan20的网关上应用ACL

  sdk_1(config-if-VLAN 20)#exit

  sdk_1(config)#interface vlan 30

  sdk_1(config-if-VLAN 30)#ip access-group 102 in ------>在 vlan30的网关上应用ACL

  sdk_1(config-if-VLAN 30)#exit

  sdk_1(config)#interface vlan 40

  sdk_1(config-if-VLAN 40)#ip access-group 103 in ------>在 vlan40的网关上应用ACL

  sdk_1(config-if-VLAN 40)#exit

  sdk_1(config)#interface vlan 70

  sdk_1(config-if-VLAN 70)#ip access-group 104 in ------>在 vlan70的网关上应用ACL

  sdk_1(config-if-VLAN 70)#exit

  sdk_1(config)#interface vlan 80

  sdk_1(config-if-VLAN 80)#ip access-group 105 in ------>在 vlan80的网关上应用ACL

  sdk_1(config-if-VLAN 80)#exit

  sdk_1(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1 ------>配置默认路由到路由器

  sdk_1(config)#exit

  sdk_1#wr

  二层交换机的配置

  Ruijie>enable ------>进入特权模式

  Ruijie#configure terminal ------>进入全局配置模式

  sdk_2(config)#hostname sdk_2 ------>配置交换机的名字为sdk_2

  sdk_2(config)#interface vlan 1 ------>进入vlan 1

  sdk_2(config-if)#ip address 192.168.1.251 255.255.255.0 ------>为vlan 1设置管理ip

  sdk_2(config-if)#exit ------>退回到全局模式

  sdk_2(config)#line vty 0 4 ------> 进入telnet密码配置模式

  sdk_2(config-line)#login ------>启用需输入密码才能telnet成功

  sdk_2(config-line)#password 123 ------> 将telnet密码设置为123

  sdk_2(config-line)#exit ------> 回到全局配置模式

  sdk_2(config)# enable secret 123 ------>配置进入特权模式的密码为123

  sdk_2(config)#enable service web-server ------>全局web功能

  sdk_2(config)#vlan 10 name guanli ------>

  sdk_2(config)#vlan 20 name xiaoshou ------>

  sdk_2(config)#vlan 30 name jishu ------>

  sdk_2(config)#vlan 40 name caigou ------> 建立各部门的vlan

  sdk_2(config)#interface range fastEthernet 0/1-14

  sdk_2(config-if-range)#switchport access vlan 10

  sdk_2(config-if-range)#exit

  sdk_2(config)#interface range fastEthernet 0/15-21

  sdk_2(config-if-range)#switchport access vlan 20

  sdk_2(config-if-range)#exit

  sdk_2(config)#interface range fastEthernet 0/22-38

  sdk_2(config-if-range)#switchport access vlan 30

  sdk_2(config-if-range)#exit

  sdk_2(config)#interface range fastEthernet 0/39-41

  sdk_2(config-if-range)#switchport access vlan 40

  sdk_2(config-if-range)#exit

  sdk_2(config)#interface gigabitEthernet 0/49

  sdk_2(config-if-GigabitEthernet 0/49)#switchport mode trunk

  sdk_2(config-if-GigabitEthernet 0/49)#end

  sdk_2#wr

  二层交换机的配置

  Ruijie>enable ------>进入特权模式

  Ruijie#configure terminal ------>进入全局配置模式

  sdk_3(config)#hostname sdk_3 ------>配置交换机的名字为sdk_3

  sdk_3(config)#interface vlan 1 ------>进入vlan 1

  sdk_3(config-if)#ip address 192.168.1.252 255.255.255.0 ------>为vlan 1设置管理ip

  sdk_3(config-if)#exit ------>退回到全局模式

  sdk_3(config)#line vty 0 4 ------> 进入telnet密码配置模式

  sdk_3(config-line)#login ------>启用需输入密码才能telnet成功

  sdk_3(config-line)#password 123 ------> 将telnet密码设置为123

  sdk_3(config-line)#exit ------> 回到全局配置模式

  sdk_3(config)# enable secret 123 ------>配置进入特权模式的密码为123

  sdk_3(config)#enable service web-server ------>全局web功能

  sdk_3(config)#vlan 50 name caiwu ------>

  sdk_3(config)#vlan 60 name zongjingban ------>

  sdk_3(config)#vlan 70 name changqu ------>

  sdk_3(config)#vlan 80 name nvr ------> 建立各部门的vlan

  sdk_3(config)#interface range fastEthernet 0/1-12

  sdk_3(config-if-range)#switchport access vlan 50

  sdk_3(config-if-range)#exit

  sdk_3(config)#interface range fastEthernet 0/13-18

  sdk_3(config-if-range)#switchport access vlan 60

  sdk_3(config-if-range)#exit

  sdk_3(config)#interface range fastEthernet 0/19-21

  sdk_3(config-if-range)#switchport access vlan 70

  sdk_3(config-if-range)#exit

  sdk_3(config)#interface range fastEthernet 0/22-23

  sdk_3(config-if-range)#switchport access vlan 80

  sdk_3(config-if-range)#exit

  sdk_3(config)#interface gigabitEthernet 0/49

  sdk_3(config-if-GigabitEthernet 0/49)#switchport mode trunk

  sdk_3(config-if-GigabitEthernet 0/49)#end

  sdk_3#wr

  路由器的配置

  路由器基本是可以通过web的,就加了两条路由,做了nat,这边就不多描述了。主要的上网过滤都是在深信服上完成了。

  ip route 192.168.1.0 255.255.255.0 192.168.2.2

  ip route 172.21.0.0 255.255.0.0 192.168.2.2


上一篇:H3C交换机密码破解方法
下一篇:H3C查看光功率、收发光情况
   蜀ICP备2020034250号-1   川公网安备 51010802000119号

售前客服

售前客服

电话:028-83252151

传真:028-85259033

咨询热线:15378180513
在线客服